Pertanyaan Kesalahan ketergantungan chrome Google - libnss3


Saya mengunduh file .deb dari situs web Google chrome. Kemudian mulai menginstal. Tapi tiba-tiba pusat perangkat lunak menunjukkan dependency not satisfied kesalahan. Beberapa hal seperti yang diberikan di bawah ini.

Dependency not satisfiable:libnss3 (>=3.14.3)

Maka saya telah mencoba semua ini.

Tapi belum terpecahkan .. Masih masalah yang sama.

Tolong beri saran tentang ini.


2
2018-01-31 09:07


asal


Jika tidak ada yang berhasil, bagaimana mereka gagal? Dan apa yang sebenarnya Anda coba? - Dan D.
Saya benar-benar tidak tahu apa masalahnya di sini. Masih itu menunjukkan hal yang sama di Pusat Perangkat Lunak. Setiap kali saya mencoba menginstal libnss3 oleh sudo apt-get install libnss3 ia mengatakan libnss3 is already the newest version. Apa yang bisa menjadi masalah. Saya pikir, versi yang terinstal tidak lebih besar dari 3.14.3. Jika itu adalah kasus bagaimana saya bisa meng-upgrade ke versi lateset. Apakah ada masalah kompatibilitas versi dengan Ubuntu OS, seperti Ubuntu 12.04 dapat menginstal versi libnss3 kurang dari 3.14.3 !! - Uvais Ibrahim
Saya hanya menebak: apakah Anda mencoba untuk berlari sudo apt-get install libnss3-dev? - Dario
Dear Dairo, Masih itu menunjukkan masalah yang sama :( - Uvais Ibrahim


Jawaban:


Mengatasinya dari tautan ini http://packages.ubuntu.com/precise/amd64/libnss3/download.

  • Seperti dikatakan menambahkan baris ini deb http://security.ubuntu.com/ubuntu precise-security main pada akhir /etc/apt/sources.list
  • sudo apt-get pembaruan
  • Ini dapat menyebabkan kesalahan kunci gpg.
  • sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 8BAF9A6F. (Lihat: https://askubuntu.com/questions/13065/how-do-i-fix-the-gpg-error-no-pubkey).
  • Sekali lagi jalankan sudo apt-get update jika kesalahan gpg telah terjadi.
  • sudo apt-get install libnss3.

Ini menginstal saya dengan libnss3 terbaru dan memecahkan masalah dengan menginstal google-chrome.


4
2018-02-24 11:49