Pertanyaan setreg.exe untuk Windows 7


Saya ingin menggunakan setreg.exe (http://msdn.microsoft.com/en-us/library/aa387700(VS.85).aspx) untuk menonaktifkan pemeriksaan pencabutan sertifikat. Namun, ini didasarkan pada versi NET yang lebih lama dari yang saya miliki. Microsoft mengatakan itu dikirim dengan .net SDK yang lebih lama, dan ketika saya mengunduh itu, coba instal, itu mengatakan sesuatu seperti 'tidak dapat menginstal SDK tanpa .net 1.1'.

Dalam artikel yang terhubung itu mengatakan untuk versi yang lebih baru saya harus menggunakan SignTool, tetapi SignTool tampaknya tidak memiliki fungsi yang saya butuhkan.

Apakah mungkin juga -

a) temukan alat yang dapat menjalankan fungsi yang saya perlukan yang tidak memerlukan saya untuk menginstal yang lama .NET

b) dapatkan setreg.exe tanpa mengunduh SDK

atau apakah saya perlu menginstal yang lama. NET pada mesin saya? Dan jika yang terakhir adalah kasusnya, apa yang harus saya lakukan untuk menginstal yang lebih tua. NET? Apakah itu akan menimpa NET saya saat ini?

Terima kasih,


2
2018-01-12 20:42


asal




Jawaban:


Kerangka .NET kompatibel ke belakang. Oleh karena itu jika saya memiliki aplikasi yang ditulis dalam .NET 2; kerangka .NET 4 saya sudah cukup.

Entah bagaimana mungkin ada peringatan dengan. NET 1.1 aplikasi seperti yang sebelum didistribusikan secara luas. NET 2 kerangka kerja.

Kerangka .NET 1.1 dapat diunduh sini dan tidak akan menimpa kerangka. NET lainnya yang mungkin telah Anda instal.


1
2018-01-12 20:48



Meskipun .NET 2-4 kompatibel dengan versi sebelumnya, namun berhenti di .NET 2. Untuk menjalankan aplikasi yang didasarkan pada .NET 1.1, Anda harus menginstal .NET 1.1. Sekarang, alat itu sendiri mungkin bukan aplikasi .NET, yang hanya dipaketkan dengan SDK. Dalam hal ini, mengekstraknya sebagai saran @therube akan cukup. - BBlake
Terima kasih, saya menginstal 1.1 dan itu bekerja dengan baik. Saya hanya perlu tahu apakah itu akan mempengaruhi versi lain. NET. Pilih yang ini benar karena itu jawaban yang saya gunakan secara pribadi tapi saya membayangkan solusi lain akan berfungsi dengan baik juga. - victoriah


Jika Anda mengunduh '.NET Framework SDK Versi 1.1', Anda dapat mengekstrak isinya. Di dalam Anda akan menemukan netfxsd1.cab. Di dalamnya Anda akan menemukan 'FL_setreg_exe _____ X86.3643236F_FC70_11D3_A536_0090278A1BB8' yang merupakan setreg.exe yang Anda cari. (Cukup ganti nama file. Ini persis sama dengan versi yang disediakan dengan W2K.)

'setup.exe' adalah file SFX .CAB.

Jadi, jika Anda memiliki metode untuk membuka file .CAB (lagi-lagi ganti nama dari .exe ke .exe.cab) cukup mudah untuk dibuka atau Anda bisa menggunakan alat, uniextract.

http://www.microsoft.com/downloads/en/confirmation.aspx?familyid=9b3a2ca6-3647-4070-9f41-a333c6b9181d&displaylang=id

http://www.legroom.net/software/uniextract


4
2018-01-12 21:09





SETREG.EX_ datang dengan Win2K (di direktori I386) jika Anda memilikinya. (Anda akan perlu menggunakan perintah EXPAND.EXE untuk memperluas SETREG.EX_ ke SETREG.EXE.)


1
2018-01-12 20:58