Pertanyaan Paksa Firefox untuk menginstal add-on


Saya ingin menginstal add-on baru di Firefox - Firesheep, tetapi ketika saya mencoba melakukannya (dari xpi file), itu mengatakan kepada saya bahwa itu dapat diinstal karena tidak kompatibel untuk 4.0.1.

Namun, pemeriksaan kompatibilitas dinonaktifkan. Adakah cara untuk memaksa add-on untuk menginstal?


4
2018-06-24 21:23


asal


Terkait: Bisakah Anda memaksa Firefox agar menjalankan plug-in "tidak kompatibel"? - slhck
seperti yang saya katakan, pemeriksaan kompatibilitas dinonaktifkan. (cara yang sama) - genesis
Saya tahu, itu sebabnya saya mengatakan "terkait" dan bukan "duplikat" :) - slhck
Sudahkah Anda menemukan jawaban? Saya mengalami masalah yang sama, saya menggunakan add-on compatibility reporter namun saya tidak bisa mendapatkan add-on untuk menginstal ... - L84


Jawaban:


Kamu dapat memakai Pelaporan Kompatibilitas Tambahan. Dengan ekstensi ini, Firefox akan menginstal semua ekstensi apakah mereka kompatibel atau tidak. Selain itu dari Addons Manager Anda dapat melaporkan (jika Anda mau) jika ekstensi yang diberikan tidak kompatibel dengan versi Firefox atau bug laporan saat ini.


0
2018-06-24 21:59



Terima kasih. Namun, itu tidak berhasil. Itu hanya menunjukkan hal yang sama seperti sebelumnya (mungkin karena add-on itu tidak memeriksa penginstalan dari file?), Namun saya tidak dapat menemukan Firesheep di mana saja di add-on database resmi - genesis
Dengan ini Anda hanya dapat memaksa Firefox untuk memasang ekstensi apa pun, tetapi tidak untuk memaksa kompatibilitas. - Realcool
Ini tidak berfungsi karena firefox 10. - naught101


Sejauh yang saya tahu, Anda dapat "meretas" suatu xpi file untuk mengubah versi maksimum yang diperlukan.

  1. Ganti nama xpi untuk zip dan ekstrak dengan perangkat lunak pengarsipan favorit Anda
  2. Temukan install.rdf file dan buka di editor teks
  3. Ubah baris berikut (jika Anda berbicara tentang Firesheep ini):

    <em:maxVersion>3.6.*</em:maxVersion>
    
  4. untuk yang satu itu:

    <em:maxVersion>4.0.1</em:maxVersion>
    
  5. Simpan file dan zip seluruh folder lagi.

  6. Ganti nama zip ke xpi dan coba pasang add-on lagi.

Perhatikan bahwa ini tidak selalu membuat pengaya kerja, tetapi setidaknya harus menginstal.


9
2018-06-24 21:36



Saya mencoba mengubahnya juga, saya mengubahnya menjadi 5.0. * - genesis
Hm, seharusnya sudah disebutkan dalam pertanyaanmu! :) Saya tidak tahu, ini telah bekerja untuk saya sekali. - slhck


Jika semuanya gagal, berikut ini beberapa tautan untuk mengunduh versi Firefox sebelumnya:
https://ftp.mozilla.org/pub/mozilla.org/firefox/releases/

Anda mungkin ingin versi 3.6:
https://ftp.mozilla.org/pub/mozilla.org/firefox/releases/3.6/win32/en-US/ 


0
2017-07-04 22:04



Ini adalah versi Firefox yang sangat lama, dan pertanyaannya sendiri mungkin tidak lagi relevan. - bwDraco


unduh mozila versi ini, seharusnya berfungsi dengan sempurna: https://ftp.mozilla.org/pub/firefox/releases/3.6.28/win32/en-GB/


0
2017-08-25 09:25



Meskipun tautan ini dapat menjawab pertanyaan, sebaiknya sertakan bagian penting dari jawaban di sini dan berikan tautan sebagai referensi. Hanya tautan jawaban yang dapat menjadi tidak valid jika laman yang ditautkan berubah. - Donald Duck